엔지니어들이 면접에서 물어야 할 질문들

이것도 geeknews에 올라온 글. 내가 보기엔 알짜정보가 많다... https://news.hada.io/topic?id=6862&utm_source=slack&utm_medium=bot&utm_campaign=T13KRBZU4 https://posthog.com/blog/what-to-ask-in-interviews "이 질문들은 매우 직설적이긴 하지만, 이에 대해 좋지 않은 반응을 보이는 회사는 좋은 직장이 아닐 수 있습니다" 이 회사는 Product-Market-Fit 한가요? PMF한지 자신에게 질문한 적이 있나요? PMF를 언제 달성했나요? 어떻게 아나요? PMF를 달성하기 위해 뭘 해야 하나요? 매출은 얼마인가요? 1년전에는 얼마였나요? 일 활성사용자(DAU)는 얼마인가요? 피해야 할 회사들 : Pre-PMF를 설명하는데 시간을 많이 쓰지 않는 창업자들 제품이나 그들이 주는 혜택이 뭔지 이해하기 어려운 회사들 문제를 찾는 해결책들 Runway가 얼마나 남아있나요? 지출이 합리적인 것처럼 보이나요? Default Alive 한가요?→ 지금은 수익성이 없지만, 자금이 바닥나기 전에 수익을 낼 수 있을만큼 빠르게 성장 가능한가 Runway는 얼마인가요? 이걸 계산하기 위한 가정은 뭔가요? 펀드레이징 계획은 어떻게 되나요? 피해야 할 회사들 : Default Alive 한지 모르거나, 신경쓰지 않는 회사 시간이 모자르거나 느려서, Default Alive 해질 것 같지 않은 회사 생존을 위해서 단시간내에 매출의 급격한 증가를 가정하는 회사 곧 자금이 바닥나기 때문에 펀드레이징을 하고 있지만, 라운드 클로징을 하지 않은 회사 문화는 어떤가요? 회사의 가치는 뭐고, 왜 그것인가요? 그 가치를 따르는 구체적인 방법들을 알려주실수 있나요? 뭘 만들지 누가 결정하나요 ? 일반적인 하루(근무일)는 어떤 모습인가요? 어떤 미래를 기대하나요 ? 어떤 것이 당신에게 동기를 부여하나요? 지금까지 가장 자랑스러운 것은 뭔가요? 회

CISCO 2960s 초기화 후 기본 설정

 이전 포스팅을 이전한 내용.

굴러다니던 스위치로 새로운 세그먼트 설정을 할 필요가 생겼기에 이리저리 조사해보고 초기화+기본설정을 했다.

초기화 부터 작업한 적은 처음이므로 메모 로서 남겨둔다.

스위치 초기화

sw> en
sw# ter len 0
sw# show run
sw# show flash:
sw# erase startup-config
sw# delete flash:vlan.dat
sw# reload

‘ter len0’ 명령어와 show 명령어들은 현재 상태를 확인 하는 차원에서 입력한 명령어다. 필요하다면 출력결과를 백업 해놓는 편이 좋을 수도 있다.

스위치는 전원을 넣은 후 부팅 하면서 ‘startup-config’ 라는 파일로부터 설정을 읽어들인다. 그러므로 ‘erase startup-config’ 명령어로 설정파일을 지워버리면 다음 부팅시에 파일이 없으니 초기화 화면을 표시해 준다.

 

마지막으로 ‘flash:vlan.dat’ 명령어 인데 vlan 설정들은 스위치 설정과 별도로 vlan.dat 파일에 들어 있으니 이 파일을 지워두지 않으면 스위치 재설정 후 vlan 정보는 초기화 이전의 데이터가 그대로 남아 있는 현상이 발생한다.

초기설정

스위치를 초기화 하고 재부팅을 시키면 아래와 같은 초기설정 화면이 나온다. 호스트명, 관리IP어드레스 등을 입력해준다.

Would you like to enter the initial configuration dialog? [yes/no]:yes
 
Would you like to enter basic management setup? [yes/no]:yes
  Enter host name [Switch]:2960S-My-SW
  Enter enable secret:
  Enter enable password:
  Enter virtual terminal password:
  Configure SNMP Network Management? [no]:no
Enter interface name used to connect to the
management network from the above interface summary:FastEthernet0/24
Configuring interface FastEthernet0/48:
  Configure IP on this interface? [no]:yes
    IP address for this interface: 192.168.0.254
    Subnet mask for this interface [255.255.255.0] : 255.255.255.0
    Class C network is 192.168.0.0, 24 subnet bits; mask is /24
Would you like to enable as a cluster command switch? [yes/no]:no
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]:2
2960S-My-SW>

snmp같은 것들은 환경에 맞추어서, 목적에 맞추어서 입력 or 무시

상세설정

중요한 설정값들은 공개가 힘드니 적당히 변경해서 기술하니 약간 이상한 곳이 있을지도.

sw> en
sw# ter len 0
sw# conf t
sw(conf)# no service dhcp
sw(conf)# service tcp-keepalives-in
sw(conf)# service sequence-numbers
sw(conf)# clock timezone JST 9 0
sw(conf)# no ip source-route
sw(conf)# no ip domain-lookup
sw(conf)# no ip igmp snooping
sw(conf)# vtp domain mydomain
sw(conf)# vtp mode transparent
sw(conf)# spanning-tree mode rapid-pvst
sw(conf)# spanning-tree portfast bpduguard default
sw(conf)# spanning-tree extend system-id
sw(conf)# spanning-tree vlan 10 priority 12288
sw(conf)# service password-encryption
sw(conf)# errdisable recovery cause udld
sw(conf)# errdisable recovery cause bpduguard
sw(conf)# errdisable recovery interval 600
sw(conf)# vlan 10
sw(conf-vlan)# name VLAN10
sw(conf-vlan)# end
sw# conf t
sw(conf)# int vlan10
sw(conf-if)# ip address 192.168.0.254 255.255.255.0
sw(conf-if)# ip default-gateway 192.168.0.1
sw(conf-if)# no ip redirects
sw(conf-if)# no ip unreachables
sw(conf-if)# no ip proxy-arp
sw(conf-if)# no ip http server
sw(conf-if)# no ip http secure-server
sw(conf-if)# end
 
sw# conf t
sw(conf)# int Gi0/1
sw(conf-if)# switchport mode access
sw(conf-if)# switchport access vlan 10
sw(conf-if)# no cdp enable
sw(conf-if)# exit
///// 반복 /////
sw(conf)# int Gi0/24
sw(conf-if)# switchport mode access
sw(conf-if)# switchport access vlan 6
sw(conf-if)# spanning-tree portfast
sw(conf-if)# no cdp enable
sw(conf-if)# exit
sw# conf t
 
sw(conf)# ntp source vlan6
sw(conf)# ntp server 192.168.0.1
sw(conf)# end
sw# write memory
sw# copy running-config startup-config
sw# exit

특별한 설정은 없다. ntp설정해주고, VLAN10설정해주고, 모든 포트들을 VLAN10으로 지정해주었다.

그리고 다른 VLAN10 스위치와 연결할 예정이니 spanning-tree도 지정해주었다.

댓글

이 블로그의 인기 게시물

curl 명령어 옵션

Macbook M1에서 karabiner를 이용한 영어/한글/일본어 입력 변환